QLD Outage
Major incident
Storman Cloud
07-06-26 10:36 AM NZST
· 4 hours, 41 minutes
Updates
Resolved
June 7, 2026 · 03:17 PM NZST
Storman Cloud access has been restored for our QLD facilities, we apologise for the inconvenience caused. Our team are continuing to monitor these systems to ensure stability.
Issue
June 7, 2026 · 10:36 AM NZST
We are currently aware that some users in Queensland may be experiencing an issue affecting access to Storman Cloud. Our team is investigating this as a high priority, and we’ll provide an update as soon as possible. We appreciate your patience.
← Back
Storman Software - AU/NZ