Online Sign Up and Resign Contract

Major incident Storman Cloud Storman Portal
20-04-26 01:20 PM NZST · 5 hours, 56 minutes

Updates

Resolved

Earlier today, we experienced an issue with Storman Online booking. This matter has been now resolved, and we apologise for any inconvenience this caused you. If you have any questions or concerns, please feel free to contact our Support team.

April 20, 2026 · 07:16 PM NZST
Investigating

We’re aware that some users may be experiencing performance issues while using using online sign ups and re-sign contract. Our team is currently working on this, and we’ll provide an update once resolved. Thank you for your patience!

April 20, 2026 · 01:20 PM NZST

← Back