System Outage
Minor incident
Storman Cloud
Storman Portal
Storman REST API
Storpay (legacy)
Online MoveIns (legacy)
11-12-25 01:04 PM NZDT
· 26 minutes
Updates
Resolved
December 11, 2025 · 01:29 PM NZDT
Earlier today, we experienced a brief issue that may have interrupted use of Storman Cloud for some of our Victorian sites. This matter has been now resolved, and we apologise for any inconvenience this caused you. If you have any questions or concerns, please feel free to contact our Support team.
Issue
December 11, 2025 · 01:04 PM NZDT
We are currently aware of an issue that may be affecting the use of Storman Cloud for some of our Victorian facilities. Our team is investigating this as a high priority, and we’ll provide an update as soon as feasible. We appreciate your patience.
← Back
Storman Software - AU/NZ