System Outage

Major incident Storman Cloud Storman Portal Storman REST API Storpay (legacy) Online MoveIns (legacy)
06-11-25 11:27 AM NZDT · 1 hour, 20 minutes, 1 second

Updates

Resolved

Earlier this morning, we experienced a brief outage that may have interrupted your use of Storman Cloud. This matter has been now resolved, and we thank you for your patience while we worked on this. If you have any questions or concerns, please feel free to contact our Support team.

November 6, 2025 · 12:46 PM NZDT
Issue

We are currently aware that some users in South and Western Australia may be experiencing an issue affecting access to Storman Cloud. Our team is investigating this as a high priority, and we’ll provide an update as soon as possible. We appreciate your patience.

November 6, 2025 · 11:27 AM NZDT

← Back