System Outage

Major incident Storman Cloud Storman Portal Storman REST API
18-10-25 11:08 AM NZDT · 6 hours, 31 minutes

Updates

Resolved

Earlier today, we experienced a large outage impacting our Victorian facilities. This matter has now been resolved, and we apologise for any inconvenience this caused you.

October 18, 2025 · 05:40 PM NZDT
Issue

We are currently aware of an unplanned outage affecting Storman Cloud, Storman Portal, and the REST API for users in Victoria, Australia. Our team is working on this as a high priority, and we’ll provide an update shortly. We appreciate your patience.

October 18, 2025 · 11:08 AM NZDT

← Back