504 errors 7th October 2025 (round 2)
Major incident
Storman Cloud
07-10-25 01:05 PM NZDT
· 1 hour, 44 minutes
Updates
Resolved
October 7, 2025 · 02:49 PM NZDT
RESOLVED - Earlier today, you may have experienced access issues while using Storman Cloud . We’ve resolved this, and all systems are go - thank you for your patience during this time! If you have any questions or concerns, feel free to reach out to our support team.
Investigating
October 7, 2025 · 01:05 PM NZDT
We’re aware that some users may still be experiencing access issues while using Storman Cloud and 504 errors will be showing on the load of a page. Our team is currently investigating this and seeking a root cause and we’ll provide an update once resolved. Thank you for your patience!
← Back
Storman Software - AU/NZ