503 errors for cloud 30/09/2025
Major incident
Storman Cloud
30-09-25 01:10 PM NZDT
· 25 minutes
Updates
Resolved
September 30, 2025 · 01:35 PM NZDT
Earlier today, you may have experienced a brief outage that interrupted your use of Storman Cloud due to an upstream technical fault. This matter has been now resolved. Thank you for your patience!
Investigating
September 30, 2025 · 01:10 PM NZDT
We are currently aware of an outage affecting Storman Cloud that may be presenting you with “Error 503 - Service Unavailable” or similar. Our team is investigating this as a high priority, and we’ll provide an update in the next thirty minutes. We appreciate your patience.
← Back
Storman Software - AU/NZ