AU-13 connectivity issues 12/08/2025
Major incident
Storman Cloud
Storman Portal
12-08-25 10:36 AM NZST
· 22 minutes
Updates
Resolved
August 12, 2025 · 10:58 AM NZST
The connectivity issues being experienced this morning by some users have been resolved and we appreciate your patience!
Investigating
August 12, 2025 · 10:36 AM NZST
Please be advised that we are investigating some connectivity issues for Storman Cloud and Storman Portal that are being experienced currently.
We will be in touch with an update soon and appreciate your patience!
← Back