System Outage

Major incident Storman Cloud Storman Portal Storman REST API Storpay (legacy) Online MoveIns (legacy)
22-05-25 10:57 AM NZST · 1 hour, 37 minutes

Updates

Resolved

Earlier today, we experienced a brief outage that may have interrupted your use of Storman Cloud. This matter has been now resolved. You may need to re-process credit card payments attempted during this window, or re-send ID verification links to new storers. If you observe any failed refund attempts, please contact our Support team so we can resolve for you. Thank you for your patience.

May 22, 2025 · 12:33 PM NZST
Issue

We are currently aware of an issue affecting areas of Storman Cloud and Portal instances. Please be assured our team is investigating this as a high priority, and we’ll provide an update as soon as possible. We appreciate your patience.

May 22, 2025 · 10:57 AM NZST

← Back