Degraded Performance
Major incident
Storman Portal
20-05-25 11:06 AM NZST
· 1 hour, 6 minutes
Updates
Resolved
May 20, 2025 · 12:11 PM NZST
Earlier today, you may have experienced performance issues while using Storman Portal: (online payments, online moveins, the re-sign portal and the customer portal.). We’ve resolved this, and all systems are go - thank you for your patience during this time! If you have any questions or concerns, feel free to reach out to our support team.
Issue
May 20, 2025 · 11:06 AM NZST
We’re aware that some users may be experiencing performance issues while using Storman Portal: (online payments, online moveins, the re-sign portal and the customer portal. Our team is currently investigating this, and we’ll provide an update once resolved. Thank you for your patience!
← Back