Power cut in Brisbane office 10/03/2025
Minor incident
Storman Cloud
10-03-25 10:34 AM NZDT
· 7 hours, 5 minutes
Updates
Resolved
March 10, 2025 · 05:37 PM NZDT
The power outage that affected internet services in our Brisbane office has now been resolved and we expect to return to a normal service level from tomorrow morning when we have staff back in the office. Thanks again for your patience!
Issue
March 10, 2025 · 10:34 AM NZDT
Due to Cyclone Alfred impacting power and internet services across Queensland; a lot of our team have limited or delayed access to the resources we need to assist you. This may lead to longer than usual response times today - live chat and emails will still be answered and we thank you for your patience!
We hope our Queensland facilities and managers stay safe and dry!
← Back