Ezidebit Payment Issue

Major incident Storman Cloud Storman Portal Storman REST API Storpay (legacy) Online MoveIns (legacy)
15-02-25 01:18 PM NZDT · 2 hours, 53 minutes

Updates

Resolved

Ezidebit have advised that according to their monitoring systems, service via the third party provider has been restored and payments can now be processed. This situation is still being actively monitored at this time for stability purposes and any updates will be posted to https://ezidebit.status.io/. Ezidebit can be reached on [email protected] or by calling 1300 561 014 (AU) or 0800 478 483 (NZ), or reach out to Storman support if needed.

February 15, 2025 · 04:11 PM NZDT
Investigating

IMPORTANT: Ezidebit have advised that a downstream service provider is experiencing a partial outage, impacting credit card processing in New Zealand. Though we do not yet have an estimated resolution time, their teams are actively working to resolve this matter. Thank you for your continued patience and please continue to check https://ezidebit.status.io/ for updates. We will also communicate when this has been resolved.

February 15, 2025 · 01:18 PM NZDT

← Back