Ezidebit partial downtime

Minor incident Storman Cloud
16-10-24 10:11 AM NZDT · 1 hour, 34 minutes

Updates

Resolved

The incident that Ezidebit was investigating with one of the downstream vendors in NZ has now been resolved and credit card payments should be working again as expected. If you have any questions or concerns, feel free to reach out to our support team.

October 16, 2024 · 11:44 AM NZDT
Investigating

Please be advised that Ezidebit is currently experiencing some partial downtime with one of its downstream vendors in New Zealand and credit card payments for this region may be affected due to this. Please visit https://ezidebit.status.io/ for updates and another update will be provided once this is resolved. Thanks for your patience!

October 16, 2024 · 10:11 AM NZDT

← Back