Storman Cloud HUB NSW degraded service
Minor incident
Storman Cloud
07-06-24 05:33 PM NZST
· 11 minutes
Updates
Resolved
June 7, 2024 · 05:43 PM NZST
Issue is now resolved and Storman Cloud is fully operational, thanks for your patience!
Issue
June 7, 2024 · 05:33 PM NZST
We are experiencing an issue with Storman Cloud in NSW, we hope to return to service very soon
← Back