NZ Cloud Hub slow/issues 22/04/24
Major incident
Storman Cloud
22-04-24 08:18 AM NZDT
· 14 minutes
Updates
Resolved
April 22, 2024 · 08:32 AM NZDT
We have resolved the performance issues being reported by some NZ clients this morning and are looking into the root cause now. Thanks again for your patience.
Investigating
April 22, 2024 · 08:18 AM NZDT
We are aware of performance issues in Storman Cloud with some New Zealand clients this morning and are currently investigating with high priority. We will update you within the next hour and appreciate your patience!
← Back