Ezidebit payment failures for NZ 26/03/24

Minor incident Storman Cloud
26-03-24 10:38 AM NZDT · 1 hour, 33 minutes

Updates

Resolved

In relation to the Ezidebit payment failures last night for NZ, we have found the scope of the affected clients and will be reaching out to them individually for remediation. Thanks for your patience!

March 26, 2024 · 12:11 PM NZDT
Investigating

Please be advised that we have been made aware from Ezidebit that there were payment failures last night around the time of overnight processing and this affected BNZ and ASB. You will see a result of “Unable to process update - Declined (WSvc)” on the Autopay report for any affected customers and we’d ask you not to do anything further until we provide an update later this morning. Our team is investigating this as a high priority and we appreciate your patience.

March 26, 2024 · 10:38 AM NZDT

← Back