Issue affecting agreement generation via Storman Move-Ins.

Minor incident Storman Portal
11-12-23 09:04 PM NZDT · 39 minutes

Updates

Resolved

An earlier issue impacting our updated Storman Move-ins platform, where agreements may not have been generated correctly on sign-up completion, has since been resolved. Thank you for your patience.

December 11, 2023 · 09:41 PM NZDT
Issue

We are currently investigating an issue impacting our updated Storman Move-ins platform, where agreements may not have been generated correctly on sign-up completion. We are investigating this urgently and will contact any impacted sites directly with further information as it comes to hand. Thank you for your patience.

December 11, 2023 · 09:04 PM NZDT

← Back