Actively Investigating

Major incident Storpay (legacy)
08-11-23 03:54 PM NZDT · 2 hours, 33 minutes

Updates

Resolved

Earlier today, we experienced an extended outage that may have interrupted your use of StorPay. This matter has been now resolved, and we apologise for any inconvenience this caused you.

November 8, 2023 · 06:28 PM NZDT
Investigating

Earlier today, we experienced an extended outage that may have interrupted your use of StorPay. This matter has been now resolved, and we apologise for any inconvenience this caused you.

November 8, 2023 · 06:28 PM NZDT
Investigating

We are currently aware of an issue affecting StorPay. Our team is investigating this as a high priority, and we’ll provide an update soon. We appreciate your patience.

November 8, 2023 · 03:54 PM NZDT

← Back