Degraded Performance for Storman Cloud
Minor incident
Storman Cloud
15-09-23 11:49 AM NZST
· 19 minutes
Updates
Resolved
September 15, 2023 · 12:01 PM NZST
Earlier today, you may have experienced performance issues while using Storman Cloud. We’ve resolved this, and all systems are go - thank you for your patience during this time. If you have any questions or concerns, feel free to reach out to our support team.
Issue
September 15, 2023 · 11:49 AM NZST
We’re aware that some users may be experiencing performance issues while using Storman Cloud. Our team is currently investigating this urgently to understand the cause and find a resolution, and we’ll provide an update once resolved. Thank you for your patience!
← Back