Storman MoveIns intermittent issues

Major incident Storman Portal
28-02-23 02:13 PM NZDT · 1 hour, 35 minutes

Updates

Resolved

Earlier today, we experienced intermittent issues across a [ 3-4 hour period ] that may have interrupted your customer’s signing up online or in-store. This matter has been now resolved, and we apologise for any inconvenience this caused you.

February 28, 2023 · 03:49 PM NZDT
Issue

We’re aware that some users may be experiencing issues using the [signup at home link] and the [in-store landing page] for Storman (online) MoveIns. Our team is currently investigating this, and we’ll provide an update once resolved. Thank you for your patience!

February 28, 2023 · 02:15 PM NZDT

← Back